Kunngjøringer

Collapse
No announcement yet.

Forumet sliter med SSL forbindelsen

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Grim
    replied
    Ah, da er det ikke bare meg...

    Leave a comment:


  • VVV
    replied
    Originally posted by Grim View Post
    Sånn ca 5/6 så får jeg feilmelding i forumet fra Chrome:

    This site can’t provide a secure connection

    forum.klanen.no sent an invalid response.
    Try running Windows Network Diagnostics.
    ERR_SSL_PROTOCOL_ERROR

    Når jeg sjekker i wireshark (gadd ikke decrypte) så sender jeg Application data med TLSV1.2 til Forumet, forumet svarer med en TCP ACK og så en TLSV1.2 alert (Level: Fatal, Description: Unexpected Message) og så sender forumet en TCP FIN, ACK for å avslutte TCP Session. Jeg sender da en TCP ACK til TLS Alert'en jeg fikk, en TLS Encrypted Alert og så en TCP FIN ACK. Forumet svarer med to TCP RST tilbake.

    tl;dr:
    Forumet sender SSL flass når jeg ber om data, og shutter ned TCP session. Ev. så klarer den ikke å decrypte meldinga mi. Det kan være at den har resatt eksisterende TCP session uten å si ifra til meg, og har dermed ikke en TLS handshake liggende. Jeg kan for lite om TLS/SSL til å skjønne hva som skjer her. Si ifra om dere vil ha Wireshark fila som viser dette.
    Mange kommentarer om samme sak de siste dagene også på denne tråden.

    Leave a comment:


  • Grim
    started a topic Forumet sliter med SSL forbindelsen

    Forumet sliter med SSL forbindelsen

    Sånn ca 5/6 så får jeg feilmelding i forumet fra Chrome:

    This site can’t provide a secure connection

    forum.klanen.no sent an invalid response.
    Try running Windows Network Diagnostics.
    ERR_SSL_PROTOCOL_ERROR

    Når jeg sjekker i wireshark (gadd ikke decrypte) så sender jeg Application data med TLSV1.2 til Forumet, forumet svarer med en TCP ACK og så en TLSV1.2 alert (Level: Fatal, Description: Unexpected Message) og så sender forumet en TCP FIN, ACK for å avslutte TCP Session. Jeg sender da en TCP ACK til TLS Alert'en jeg fikk, en TLS Encrypted Alert og så en TCP FIN ACK. Forumet svarer med to TCP RST tilbake.

    tl;dr:
    Forumet sender SSL flass når jeg ber om data, og shutter ned TCP session. Ev. så klarer den ikke å decrypte meldinga mi. Det kan være at den har resatt eksisterende TCP session uten å si ifra til meg, og har dermed ikke en TLS handshake liggende. Jeg kan for lite om TLS/SSL til å skjønne hva som skjer her. Si ifra om dere vil ha Wireshark fila som viser dette.
Working...
X